☰
解决在docker中部署的jenkins使用`withDockerContainer` 报错问题 Cannot run program “docker“: Exec failed
2026/9/28 4:40:39 网站建设 项目流程

执行如下命令

ls -l /usr/bin/docker

ls: cannot access '/usr/bin/docker': No such file or directory

根因:

withDockerContainer是docker-workflow插件,本质是在节点上调用本地docker二进制执行命令

重新创建镜像,将主机的docker路径挂载到jenkins容器中

services: myjenkins: image: jenkins/jenkins:2.583 # 容器名字 container_name: myjenkins restart: always user: root ports: - "8080:8080" - "50000:50000" volumes: # 沿用原有持久卷,数据不丢失 - jenkins-data:/var/jenkins_home # 支持容器内调用docker - /var/run/docker.sock:/var/run/docker.sock # 新增下面的挂载,解决找不到docker路径问题, /usr/bin/docker - /usr/bin/docker:/usr/bin/docker environment: - TZ=Asia/Shanghai # 入口脚本:先修改时区软链接,再启动jenkins,不生效,还在找原因中 # entrypoint: ["/bin/bash", "-c", "ln -sf /usr/share/zoneinfo/Asia/Shanghai /etc/localtime && exec /usr/local/bin/jenkins.sh"] volumes: jenkins-data:

需要专业的网站建设服务?

联系我们获取免费的网站建设咨询和方案报价,让我们帮助您实现业务目标

立即咨询